読者です 読者をやめる 読者になる 読者になる

rbenvクックブックでインストールしたRubyをRecipe内で使うには

Chefのrbenvクックブックを使うと簡単にRubyがインストールできます。

で困ったことが出てきて、Recipeのbashリソース内でrbenvでインストールしたRubyのバージョンのRubyを使おうとしたら Chef内のRuby(1.9.3)が使われて、おいおい…となったんですよ。

解決策は、rbenv_scriptリソースを使う。

ちゃんとドキュメント読めって話ですね。。